The vendor has taken steps to mitigate its issue. Preliminary monitoring indicates that phone service has been restored and the Pitt Police phone number (412-624-2121) is available.
Pitt Digital continues to closely monitor service to ensure stability and reliability. We will update status.pitt.edu once we have confirmed full service resolution.
Posted Jul 29, 2025 - 17:55 EDT
Investigating
Pitt Digital is working to resolve a vendor issue that is affecting the ability of University phone numbers to receive and place phone calls. Individuals receive a busy signal when attempting calls.
Pitt Digital is working with our vendor partner, Zito, to resolve the issue and restore full service as quickly as possible. Individuals who are unable to reach the Pitt Police phone number (412-624-2121) should call 911 in the event of an emergency. The vendor is working to resolve the issue, which affects customers beyond the University of Pittsburgh.
We will notify the University community when the issue is resolved. In the meantime, updates will be posted to status.pitt.edu as more information becomes available.
Posted Jul 29, 2025 - 17:30 EDT
This incident affected: Communication and Collaboration (Voice and Data Services (Telephony)).