Pitt Digital has worked with the vendor to resolve the issue and restore full service. We continue to monitor service closely and will post additional updates to status.pitt.edu as needed.
Posted Jul 31, 2025 - 16:47 EDT
Update
Pitt Digital has identified the issue and is working with our vendor partner to take steps to mitigate it. Updates will be posted to status.pitt.edu.
Posted Jul 31, 2025 - 13:33 EDT
Investigating
Pitt Digital is aware of an intermittent issue that is affecting the ability of some individuals to change their University password. The issue does not affect the ability of individuals to log into or access University services.
Pitt Digital is working to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Jul 31, 2025 - 12:18 EDT
This incident affected: Accounts, Access, and Information Security (Account Management (accounts.pitt.edu)).